Join the Beta

We're in the middle of running a beta of Frenlo, and we'd love to have you check it out.

We're letting people in over time as we feel confident that things are stable enough for you to have a great experience.

Frenlo requires iOS 14 or later.